局域网技术与组网工程实验报告上交1-3(6200字)

来源:m.ttfanwen.com时间:2017.12.20

计算机局域网技术与组网工程实验报告

学期_________________日期_______________学院________________________成绩_________ 班级_________________姓名_______________学号_______________指导教师______________

实验名称: 实验1 认识交换机

实验目的:了解交换机的基本知识,熟悉交换机的CLI;掌握交换机的基本配置命令体系。 实验内容:1. 恢复成出厂值 2.用向导配置交换机;3. 交换机的配置模式;4. 交换机的命令

行配置方式。

实验要求:熟练掌握交换机的命令行操作模式。配置交换机的设备名称等相关信息。配置交换

局域网技术与组网工程实验报告上交13

局域网技术与组网工程实验报告上交13

(1)拓扑设计

(2)设备配置

步骤1 交换机命令行操作模式的进入。

Switch>

Switch>enable //进入特权模式 Switch#

Switch#configure terminal //进入全局配置模式. Switch(config)#interface fastEthernet 0/1 //进入交换机F0/1的接口模式 Switch(config-if)#

Switch(config-if)#exit //退回到上一级操作模式 Switch(config)#

Switch(config-if)#end //直接退回到特权模式 步骤2 交换机命令行操作模式的进入。

Switch>

Switch>enable //进入特权模式 Switch#

Switch#set default

Switch#write

Switch#reload

步骤3 交换机的基本配置。

Switch>en

Switch#conf t

Switch(config)#hostname SW1 //进入特权模式修改交换机的名称,可以根据自己的喜好定义

SW1(config)#line vty 0 4

SW1(config-line)#logg

SW1(config-line)#logging sy

SW1(config-line)#logging synchronous //在线路模式下配置输出同步

SW1(config)#enable password cisco //配置登录密码为cisco

SW1(config)#int vlan 1

SW1(config-if)#ip add 192.168.1.1 255.255.255.0 //配置管理地址 方便管理员进行管理

实验结果:

经过相应的配置,用show命令进行检查,并用电脑telnet管理ip、管理交换机,经检查,没有问题。 实验体会:

1、通过本次实验,我发现在交换机的命令行模式下可以按TAB键补全命令,但是这个命令必须是唯一的,如果不是,那么就会出现错误。

2、交换机上面严格的等级,进进入相应的等级,就会有相应的权限,才会有相应的命令,可以通过输入“?”来查看相应权限下的相应命令。

计算机局域网技术与组网工程实验报告

学期_________________日期_______________学院________________________成绩_________ 班级_________________姓名_______________学号_______________指导教师______________

实验名称: 实验2 交换机VLAN的划分与跨交换机VLAN的配置

实验目的:掌握交换机VLAN的概念,学会配置交换机的虚拟网,掌握不同交换机的VLAN划分方

法。

实验内容:1. 单交换机VLAN划分2. 跨交换机VLAN划分。

实验要求:通过划分PORT VLAN实现本交换隔离。通过划分Port VLAN 来实现交换机的端口隔离,

然后使在同一个VLAN里的计算机系统能跨交换机进行相互通信,而在不同 VLAN里

局域网技术与组网工程实验报告上交13

(1)拓扑设计

局域网技术与组网工程实验报告上交13

局域网技术与组网工程实验报告上交13

局域网技术与组网工程实验报告上交13

单交换机VLAN划分 跨交换机VLAN划分

(2)设备配置

内容1 单交换机VLAN划分

步骤1 在未划分vlan前两台pc互相ping可以通。

步骤2 创建vlan,将端口分配到vlan

switch#config t //进入全局配置模式

switch(config)#vlan 2 //创建vlan 2

switch(config)#vlan3 //创建vlan 3

switch(config)#interface fastEthernet 0/1 //进入端口配置模式 switch(config-if)#switchport mode access //确定端口模式为access

switch(config-if)#switchport access vlan 2 //将f 0/1端口加入vlan2中

Switch(config-if)#int f0/2 //进入端口配置模式

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 3 //将f0/2端口加入vlan3中

步骤3 测试两台pc互相ping不通

局域网技术与组网工程实验报告上交13

内容2 跨交换机VLAN划分

步骤1 在交换机switch1上创建vlan 2,并将f 0/1口端口划分到vlan2中

Switch1#configure terminal //进入全局配置模式

Switch1(config)#vlan 2 //创建vlan 2

Switch1(config-vlan)#exit

Switch1(config)#interface fastEthernet 0/1 //进入端口配置模式

Switch1(config-if)#switchport access vlan 2

步骤2 在交换机switch1上创建vlan 3,并将f 0/2端口划分到vlan3中

Switch1(config)#vlan 3 //创建vlan 3

Switch1(config-vlan)#exit

Switch1(config)#interface fastEthernet 0/2 //进入端口配置模式

Switch1(config-if)#switchport access vlan 3

步骤3 把交换机switch1与交换机switch2相连的端口定义为trunk模式

Switch1(config)#interface fastEthernet 0/24 //进入端口配置模式

Switch1(config-if)#switchport mode trunk //将端口定义为trunk模式

步骤4 在交换机switch2上创建vlan 2,并将f 0/1端口划分到vlan2中

Switch2#configure terminal //进入全局配置模式

Switch2(config)#vlan 2 //创建vlan 2

Switch2(config)#interface fastEthernet 0/1 //进入端口配置模式

Switch2(config-if)#switchport access vlan 2

步骤5 验证pc1与pc3能相互通信,但pc2和pc3不能互相通信

局域网技术与组网工程实验报告上交13

局域网技术与组网工程实验报告上交13

实验结果:

PC1可以ping通PC3,不能ping通PC2

实验体会:

1. Vlan 1 属于系统的默认vlan,不可以被删除。

2. 同一个vlan下的主机能够相互通信,不同vlan下的主机不能相互通信,vlan隔离广播域

3. 跨交换机通信要将连接两台交换机的端口设置为trunk端口。

计算机局域网技术与组网工程实验报告

学期_________________日期_______________学院______________________成绩_________ 班级_______________姓名_______________学号_______________指导教师______________

实验名称: 实验3 交换机级联、堆叠、链路聚合与生成树协议

实验目的:理解交换机级联与堆叠的区别;理解广播风暴的产生原因;掌握堆叠、链路聚合

与生成树协议的配置方法。

实验内容:1.交换机的级连 2. 交换机的堆叠 3.交换机的链路聚合4. 交换机生成树协议。 实验要求:拓展网路接口数,统一化管理交换机;增加交换机之间的传输带宽,并实现链路

局域网技术与组网工程实验报告上交13

局域网技术与组网工程实验报告上交13

(1)拓扑设计

(2)设备配置

步骤1 交换机A的基本配置

SwitchA>enable //进入特权模式

SwitchA#configure terminal //进入全局配置模式

SwitchA(config)#vlan 2 //创建vlan2端口

SwitchA(config-vlan)#exit

SwitchA(config)#interface fastEthernet 0/1 //进入端口配置模式

SwitchA(config-if)#switchport access vlan 2

步骤2 在交换机SwitchA上配置聚合端口

SwitchA#configure terminal //进入全局配置模式 SwitchA(config)# interface Port-channel 1 //创建聚合接口1 SwitchA(config-if)#switchport mode trunk //配置AG模式为trunk SwitchA(config)#interface range fastEthernet 0/2-3 //进入接口0/2和0/3 SwitchA(config-if-range)# channel-group 1 mode on //配置接口0/2和0/3属于AG1 验证测试:验证接口fastEthernet 0/2和0/3 属于AG1

SwitchA#show etherchannel summary

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+----------------------------------------------

1 Po1(SU) - Fa0/2(P) Fa0/3(P)

步骤3:交换机B的基本配置

SwitchB>enable //进入特权模式

SwitchB#configure terminal //进入全局配置模式

Switch(config)#hostname SwitchB //将交换机命名为SwitchB

SwitchB(config)#vlan 2 //在SwitchB上创建vlan2

SwitchB(config)#interface fastEthernet 0/1 //进入端口配置模式

SwitchB(config-if)#switchport access vlan 2 将f0/1划分到vlan2中

步骤4:在交换机SwitchB上配置聚合端口

SwitchB#configure terminal

SwitchB(config)# interface Port-channel 1 //创建聚合接口1

SwitchB(config-if)#switchport mode trunk //配置AG模式为trunk SwitchB(config-if)#exit

SwitchB(config)#interface range fastEthernet 0/2-3 //进入接口0/2和0/3

SwitchB(config-if-range)# channel-group 1 mode on //配置接口0/2和0/3属于AG1 验证测试:验证接口fastEthernet 0/2和0/3 属于AG1

SwitchA#show etherchannel summary

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports

------+-------------+-----------+----------------------------------------------

1 Po1(SU) - Fa0/2(P) Fa0/3(P)

步骤5.验证当交换机之间的一条链路断开时,PC1与PC2仍能互相通信

局域网技术与组网工程实验报告上交13

实验结果:

实验证明,PC1能ping通PC2,在链路断一条的情况的下仍然能继续ping通,证明了链路聚合增加了网络的稳定性。

实验体会:

1、只有同类型端口才能聚合为一个AG端口。

2、所有物理端口必须属于同一个VLAN。

3、两端的聚合组的编号不一定要一致,选择的模式要相同。


第二篇:自考“局域网技术与组网工程”复习资料汇总1 14000字

(/club/5346389)欢迎加入...欢迎交流...止不住的惊喜等着你.........自考“局域网技术与组网工程”复习资料汇总(1-11)自考“局域网技术与组网工程”复习资料(1) 1.局域网存在的两个重要特征  (1)它用带地址的帧来传送数据;  (2)不存在中间交换,所以不要求路由选择。  2.局域网对应怎样的OSI层次结构  局域网需要OSI的层一: 物理层,完成物理链路;层二: 数据连路层;层三: 网络层,完成路由选择,但任何两点直接链路可用时,就不需要这样的功能。  3.局域网数据的传递(二层和三层)  (1)最上层接收来自所连接的站的发送信息;  (2)通过服务访问点(SAP)向下层交换信息,SAP是相邻层的逻辑接口;  (3)发送时将数据组装带有地址的差错检测字段的帧;  (4)接收时拆卸帧,完成地址识别和差错检测;  (5)管理链路上的通信。  4.物理层的主要功能  (1)信号的编码和译码;  (2)前导码的生成和除去(前导码用于帧同步);  (3)比特的发送和接收。  5.共享型以太网存在的主要弱点  ①受到CSMA/CD的约束,一个碰撞域的带宽是固定的;  ②在一个碰撞域的系统中,每个节点的带宽为:系统带宽/n;(n为节点数)  ③在一个碰撞域的系统中,可以是一个工作组,也可是多个工作组;  ④在多个工作组的碰撞域中,每个工作组的数据流广播到系统中所有的站,安全性不好。  ⑤覆盖范围受到限制。  6.交换型以太网的改进:  (1)每个端口可以连接网段,也可连接站点。每个端口独享10Mbps的带宽;  (2)系统的最大带宽可达到端口带宽的n倍;  (3)交换器连接了多个网段,网段上运作都是独立的,被隔离的。但如果需要的话,独立网段之间通过其端口也可建立暂时的数据通道。  (4)被交换器隔离的独立网段上数据信息流不会随意广播到其它端口上去。  7.比较令牌环与FDDI帧结构  1.)令牌环的帧帧首定界符(SD)  访问控制(AC)  帧控制(FC)  目的地址(DA)  源地址(SA)  信息(INFO)  帧检验序列(FCS)  帧尾定界符(ED)  帧状态(FS)   2.)FDDI帧结构前导码(PA)  帧首定界符(SD)  帧控制(FC)  目的地址(DA)  源地址(SA)  信息(INFO)  帧检验序列(FCS)  帧尾定界符(ED)  帧状态(FS)   说明其不同之处:1.)令牌环的帧没有前导码(PA);但增加了访问控制和帧控制,帧尾

增加了帧尾定界符(ED)和帧状态(FS),类型和数据区合并成信息字段。自考“局域网技术与组网工程”复习资料(2)8.路由器与桥接器比较:  相同点:均为网络互连设备;  不同点:  ①路由器工作在第三层,而网桥工作在第二层  ②路由器通过网络地址(IP)作为转发的依据,一般耗时较长;  网桥通过物理地址(MAC)作为转发的依据,一般耗时较短;即:网桥转发比路由器快。  ③路由器具有广播包抑制和子网隔离功能;网桥无广播包抑制和子网隔离功能。  9.从网桥、L2交换机和传统的路由器技术的局限性理解L3交换技术的背景?  1.)使用网桥的局限性  网桥的优缺点:  (1)网桥基于MAC地址,实现LAN之间的互联。优点是:网络*作简单,速度快,与OSI的其他层  无关。其易于维护且价格低廉。  (2)网桥无法实现流控,广播包从一个LAN到另一个LAN,常会引起大量的多路广播,造成网络效率降低。最严重时会造成广播风暴,是整个网络瘫痪。  (3)当网桥构成网状结构时,会产生广播包和不知道目的地址的数据包的循环问题。为此制定了  生成树的算法。即在一个网络中,任意两个终端之间只有一条路径。  (4)在某些情况下,因网桥拥塞而丢失数据包,使网络不稳定、不可靠。  (5)广播包是需要的,但太多的广播包会导致网络效率降低。  2.)路由器的引入及其局限性  *路由器的优缺点:  (1)网络分段,这是路由器最主要的功能之一。路由器可以将不同的LAN互联。  (2)路径选择,通过对数据包中的IP地址检查,选择出路径。  (3)隔离广播,路由器可以住址广播流量从一个LAN到另一个LAN,可避免广播风暴。  (4)安全性与防火墙,只有被授权的用户才能通过路由器。  (5)第三层的特殊服务,如优先权控制。  (6)广域网连接,大多数网络目前仍使用路由器作为网络连接设备。  3.)路由器的限制:  (1)路由器需对每一个数据包检查,即使是同一源地址到同一目的地址的数据包也不例外,重复工作。  (2)软件是路由器的主要实现方式,由于以上原因,路由器的吞吐量不可能很高。  (3)路由器在流量超过本身的吞吐量时,会造成数据包丢失或延误,给网络造成危害。  3.局域网交换技术的引入及其局限性  交换式网络是以交换器为中心构造的网络体系,交换式网络与多端口网桥非常相似,他们都工作在第二层,网桥交换事业是基于每个数据包的终点地址(MAC)。  交换式网

络的实现通常采用全硬件结构实现,具有速度快,可以为每一个节点提供全部网络带宽,但同网桥一样它也不具备隔离广播数据包的能力。  由此,曾取得全面成功的路有器的解决方案成为网络通信不可逾越的瓶颈。交换技术可以克服网络带宽的局限,而路由器又能解决TCP/IP中的地址问题,那么将两者技术结合起来,扬长避短,发挥各自的优点,从而解决以上问题。在这种背景下,产生了L3交换式网络技术。  10.何谓VLAN及其条件和关键问题是什么?  (1)VLAN基本上可以看成是一个广播域——一组客户工作站的集合。这些工作站不必处于同一个物理网络上,它们可以不受地理位置的限制像处于同一个LAN上那样进行通信和信息交换。可以认为一个VLAN实际上是逻辑上的网段。  (2)VLAN需要具备的条件:  ①具有能够将所连接的客户站进行逻辑分段的高性能交换机。复习资料(3)②在网上传输VLAN信息的通信协议。  ③进行VLAN间通信的第三层路由解决方案。  ④同已安装的LAN系统能够实现VLAN的兼容性和互操作性。  ⑤提供具有集中控制、配置和流量管理功能的网管方案。  (3)最为关键问题的是:  ①如何在整个网络范围内定义务VLAN中的成员,即VLAN划分方法。  ②如何在多个交换设备之间传递VLAN成员信息  ③VLAN的配置问题如何解决  ④VLAN之间的通信如何进行  11.何为虚连接、虚通路、虚通道?  12.建树系统设计所包括的五个方面和遵循的基本原则?  (1)五方面:  建设目标;建设原则;主要技术线路;方案设计原则和设备选择原则  (2)基本原则:  可用、可靠、先进、开放、可扩展、安全性和性价七原则  13.以太网的帧结构及其每段意义前导码  帧首定界符(SFD)  目的地址(DA)  源地址(SA)  类型 (TYPE)  数据区(DATA)  帧检验序列(FCS)   1.)前导码  为101010……,共56位,为了同步。  2.)帧首定界符(SFD)  为10101011,表示一帧开始。  3.)目的地址(DA)  为MAC的物理地址,共6字节。又分为单地址、多地址和广播地址。  (1)单地址:最高位是“0”;  (2)多地址和广播地址:最高位是“1”。(广播地址时,DA同时为全“1”代码) 4.源地址(SA)  同上  5.)类型(TYPE)  主要说明高层所使用的协议类型,如IP地址。  6.)数据区(DATA)  它的范围为:46~1500字节,如不够46字节,则必须填充到46字节。 7.)帧检验序列(FCS)  FCS是通过计算除前导码

、SFD和FCS以外的内容得到的。  2.4.2 以太网与IEEE802.3(CSMA/CD标准)帧结构的比较  7 1 6 6 2 46~1500 4  前导码帧首定界符(SFD)目的地址(DA)源地址(SA)类型  (TYPE)数据区(DATA)帧检验序列(FCS)  以太网帧结构  7 1 2/6 2/ 6 2 46~1500 0~46 4  前导码帧首定界符(SFD)目的地址(DA)源地址(SA)长度(L)  逻辑链路层协议单元LLC-PDU填充字段 PAD帧检验序列(FCS)  IEEE802.3(CSMA/CD标准)帧结构  说明:如果LLC-PDU<46字节,则发送站的MAC子层自动填“0”代码于填充段PAD中。  以太网与IEEE802.3的区别:  比较以太网IEEE802.3  数据段直接为网络层的分组为LLC-PDU  长度/类型类型(值大于1536D)长度(值小于1536D)  以太网帧IEEE802.3帧  DA段在最高位有意义:区分单址还是多址在最高两位有意义次高位“0”:全局管理次高位“1”:局部管理广播地址DA段,次高位“1”DA段,次高位“1”  14.动态交换方式包括那几种,并比较各自优缺点?  动态交换方式又分为存储转发和穿通两种方式。  1.) 存储转发交换方式特点:  最主要的优点:帧的可靠性传输。  原因:要进行输入、输出两次差错检验。  (1)第一次是在帧从源站到交换器输入端口  (2)第二次是从交换器输出到目的站的链路上  最主要的缺点:有较长的时间延迟,存储与发送据要进行串/并转换  2.) 穿通交换方式特点:  (1)当输入端收到帧的开始6个字节后,交换器根据目的地址查端口——地址表,获得输出端地址后,就把整个帧导向输出端口;缩短了时延。  (2)可靠性不高;  (3)适用于链路可靠性高的环境中。  (4)穿通交换方式/存储转发共用,先采用穿通交换方式,若链路可靠性差,则自动转到存储转发方式。得到最大的交换器的效率。  16.叙述令牌环网与FDDI的组成  令牌环网网卡、环路插入器、插入器电缆及环路电缆  17.路由器组网特点  1.)网络的互连  路由器可实现局域网与广域网的互连以及广域网之间的互连,路由器的功能如下:  (1)地址映射  IP——MAC地址之间的转换  (2)数据转换  路由器互连的网络的最大传输单元(MTU)不同,路由器应解决分段和重传的问题。(3)路由选择  根据路由表选择。  (4)协议转换  2.)网络的隔离  (1)路由器可以根据网络号、主机的网络地址、地址掩码、数据类型来监控、拦截和过滤信息,而网桥只能根据局域网的MAC地址和第三层协议类型来隔离信息。 

 (2)路由器具有更强的网络隔离能力,可避免广播风暴,提高整个网络的性能。  (3)路由器抑制广播风暴:当路由器收到一个寻址报文时(ARP),由于该报文的目的地址是广播地址,路由器不会将其广播,而是将自己的MAC地址发送给源主机。源主机在发送数据时就可以直接填写路由器的MAC地址,避免了路由器发广播。  注意:为什么会发生广播风暴这是因为IP和MAC的原因。  3.)流量的控制  主要采用路由算法均衡网络负载。  18.CISCO的NetFlow交换处理  传统的第三层路由技术为:  对每一个数据分组分别独立地进行处理,即使是源端和目的端相同的分组也要进行分别独立地进行处理。过程可记为:MAC——IP——MAC.  NetFlow交换如下:  (1)每一个数据分组仍然采用一般的第三层路由/交换方式,处理之后的路由器把第一个数据分组的信息记录在NetFlow的高速缓存中;  (2)后继的分组到达后,首先在高速缓存(CACHE)中进行匹配查找,如果命中,就使用高速缓存 (CACHE)中缓存的路由信息,直接进行交换转发,否则再进行通常的路由转发。  (3)NetFlow技术中,网络流的划分标准是源和目的IP地址,因此NetFlow必须首先识别一个分组所携带的源和目的IP地址域,并查找。  (4)NetFlow速度可达到每秒30万个分组。  (5)CISCO还采用了一种专用的技术,可以支持流状态信息的搜集和输出,便于管理者管理。  19.分析CISCO NetFlow“交换”的概念(意义)  (1)NetFlow仍然工作在第三层,而不是第二层。  (2)NetFlow交换是一种传统的路由转发的改进方法,即使用高速缓存(CACHE)的一个变种,在技术上做了一些改进。  (3)NetFlow并没有建立连接源和目的端系统的第二层交换路径,它只是单独的路由器上完成的。  数据分组被“交换”只有局部意义,这与通常意义上的交换是完全不同的。  20.在以太网结构中vlan互联的常用方法及其特点?  路由模式: 有边界路由、 “独臂”路由器、路由服务器/客户机、MPOA、第三层交换技术  常用的有:有边界路由、 “独臂”路由器、第三层交换技术  1.) 边界路由  边界路由指的是将路由功能包含在位于主干网络边界的每一个LAN交换设备中,此时,VLAN间的报文将由交换设备内在的路由能力进行处理,从而无需再将其传送至某个外部的路由器上,数据的转发延迟因而也将得以降低。  此种路由方式的主要优点:在于不像集中式路由那样会因中央路由站点的崩溃而导致整个网络的瘫痪。  主要的不利之处在于:相

对于统一路由功能的集中式管理而言,边界路由需要对多个物理设备进行管理。另外此种方式可能比由一个集中式路由器和多个较便宜的边界路由器组成的集中式方案在价格上要贵一些。2.) “独臂”路由器  采用“独臂”路由器的网络方案因能消除主干网上集中式处理和高延迟的路由功能而越来越受广泛的关注。  要求:  大部分报文在VLAN内传输;  少量的报文通过路由器进行传输。  这种路由器一般接在主干网上的一个交换设备上,以使得网络中的大部分报文在通过主干网时无需通过路由器进行处理,而且此种方式配置和管理起来也比较方便。此种路由模式由图8.4所示。  优点:我们可以看到同一个VLAN内的报文将用不着通过路由器而直接在交换设备间进行高速传输。  这种路由方式的不足之处在于它仍然是一种集中式的路由策略,因此在主干网上一般均设置有多个冗余“独臂”路由器,但如果网络中VLAN之间的数据传输量比较大,那么在路由器处将形成瓶颈。  3 .) 第三层交换技术  在第三层交换技术的章节中,已经详细地讨论了各种技术的原理和特点,有的技术方案本身就是一个带有路由功能的交换器。特别是基于智能可编程ASIC技术的第三层交换器,它既包括了第二层和第三层的交换功能,而且还具备路由寻址功能。因此利用它来作为网络的主干交换器,既可以根据多种方法来定义VLAN成员,继后配置VLAN,又能不附加其它路由设备来实现VLAN之间的通信。不论从网络结构还是降低网络传输延迟来说,用第三层交换技术不失是一个很好的选择。  21. L3交换技术解决方案的分类  基于核心模型和基于边缘多层混合交换模型。  1.基于核心模型的解决方案的核心思想  主要解决核心关键节点,即路由器的第三层交换技术。有两种方案:  (1)对于每一个数据包都需检查源/目的IP地址的方法,改为检查数据分组携带的网络流标志为依据,这样就大大减小了检查的时间,提高了吞吐率。  (2)完全用ASIC(专用集成电路)硬件以线速来实现路由器的路由/转发、流控、管理、服务质量等功能。  2.基于边缘多层混合交换模型的解决方案的核心思想  “一次路由,随后交换”的方案:  (1)这种方案认为网络智能应该在网络的边缘,而不是在网路的关键节点实现,因为这样可以减少网络中继点的额外开销。  (2)这种方案认为绝大多数策略和请求都在端系统上完成,少数特定的控制功能(如身份认证、防火墙、流量统计等)则集中在少数几个网络核心节点的智能系统

。  (3)这种方案认为在第三层路由一次,然后在第二层交换端到端的网络数据分组。  22.简述LAN仿真的组成部分  (1)一个仿真客户机(LEC)  (2)一个仿真服务(LE Service)  a.)仿真配置服务器(LECS)  b.)仿真服务器(LES)  c.)广播和未知服务(BUS)  23.综合布线系统有哪些子系统组成?  ①设备间②工作区③水平④垂直⑤建组群⑥管理 六个子系统组成  24.Vlan的功能  ①提高管理效率②控制广播数据③增加网络安全④减少站点移动和改变的开销⑤实现虚以工作组  25.简述环网的特点(与以太网的比较)  (1)适应中负荷的应用环境  (2)既有实事性能和优先权机制  (3)环网媒体可以使用光纤  (4)覆盖面积较大,可达几十公里26.简述10BASET以太网的特点  (1)星型拓扑结构,采用集线器作为星型的核心  (2)采用UTP,发送和接受物力上分开  (3)网络站点通过网卡直接连接集线器  27.10BASET的功能  (1)媒体上信号的再生和在定时  (2)检测碰撞  (3)端口的扩展功能  (4)混合连接10BASE5与10BASET及10BASE2以太网系统  28.简述全双工的技术特点(与传统的半双工比较)  (1)端口上采用两根双绞线或光纤收发分开,同时接受和发送,不再受CSMA/CD的约束;,在端口上发送帧不再产生帧的碰撞,已经没有碰撞域的存在了。  (2)端口之间的媒体长度仅与媒体衰耗有关,而不像传统以太网受冲突域的限制。  29.FDDI编码的特点  (1)不采用简单的强度调制编码(用有无载波来确定),因同步信号难于提取;  (2)FDDI采用两级编码的方式,第一级选用4B/5B码,效率高,并保证出现跃变;  (3)第二级编码,将4B/5B码进一步编成NRZI(非立即归零码),改善接收的可靠性;NRZI(非立即归零码)为差分编码。  (4)NRZI(非立即归零码)的编码规则:“1”用跃变表示,“0”则不跃变。  (5)4B/5B码的选择基于这样一个保证,采用NRZI(非立即归零码),在一行中不允许出现多于3个“0”的情况,提供同步信息。  (6)关于4B/5B码:除0~15数字外,其他的码还可代表其他意义,见P.75.  30.Internet的主要信息服务  电子邮件、文件传输、远程登陆、电子公告、信息浏览、高级超文本浏览、自动标题搜索,dns等  31.简述快速以太网的分类  (1)按结构分:共享和交换型  (2)按媒体分:100BASET与100BASEFX即双绞线和光纤  (3)按设备分:单台非扩展、叠堆型和厢体型  32.简述以太网

的功能模块  分两大部份:数据链路层和物理层  (1)数据链路层:LLC不列入以太网标准;MAC层分:帧的封装/解封装及控制  (2)物理层:物理信令(PLS)和媒体连接单元(MAU)和媒体三部分组成  33.解答以太网交换器的四种结构  (1)软件执行交换结构  (2)矩阵交换结构(3)总线交换结构  (4)共享存储器结构  34.简述路由器的分类  (1)采用传统的计算机结构  (2)采用并行处理结构  (3)背板采用纵横交换结构  (4)并行处理和背板采用纵横相结合的结构 26.简述10BASET以太网的特点  (1)星型拓扑结构,采用集线器作为星型的核心  (2)采用UTP,发送和接受物力上分开  (3)网络站点通过网卡直接连接集线器  27.10BASET的功能  (1)媒体上信号的再生和在定时  (2)检测碰撞  (3)端口的扩展功能  (4)混合连接10BASE5与10BASET及10BASE2以太网系统  28.简述全双工的技术特点(与传统的半双工比较)  (1)端口上采用两根双绞线或光纤收发分开,同时接受和发送,不再受CSMA/CD的约束;,在端口上发送帧不再产生帧的碰撞,已经没有碰撞域的存在了。  (2)端口之间的媒体长度仅与媒体衰耗有关,而不像传统以太网受冲突域的限制。  29.FDDI编码的特点  (1)不采用简单的强度调制编码(用有无载波来确定),因同步信号难于提取;  (2)FDDI采用两级编码的方式,第一级选用4B/5B码,效率高,并保证出现跃变;  (3)第二级编码,将4B/5B码进一步编成NRZI(非立即归零码),改善接收的可靠性;NRZI(非立即归零码)为差分编码。  (4)NRZI(非立即归零码)的编码规则:“1”用跃变表示,“0”则不跃变。  (5)4B/5B码的选择基于这样一个保证,采用NRZI(非立即归零码),在一行中不允许出现多于3个“0”的情况,提供同步信息。  (6)关于4B/5B码:除0~15数字外,其他的码还可代表其他意义,见P.75.  30.Internet的主要信息服务  电子邮件、文件传输、远程登陆、电子公告、信息浏览、高级超文本浏览、自动标题搜索,dns等  31.简述快速以太网的分类  (1)按结构分:共享和交换型  (2)按媒体分:100BASET与100BASEFX即双绞线和光纤  (3)按设备分:单台非扩展、叠堆型和厢体型  32.简述以太网的功能模块  分两大部份:数据链路层和物理层  (1)数据链路层:LLC不列入以太网标准;MAC层分:帧的封装/解封装及控制  (2)物理层:物理信令(PLS)和媒体连接单元(MA

U)和媒体三部分组成  33.解答以太网交换器的四种结构  (1)软件执行交换结构  (2)矩阵交换结构(3)总线交换结构  (4)共享存储器结构  34.简述路由器的分类  (1)采用传统的计算机结构  (2)采用并行处理结构  (3)背板采用纵横交换结构  (4)并行处理和背板采用纵横相结合的结构35.试述传统局域网与ATM提供服务的区别  (1)ATM采用面向连接的点对点的通道服用技术传输;  (2)传统的局域网是共享媒体的,所以交易的实现广播和组播,而ATM较难实现;  (3) 传统的局域网以不定长的帧单位传输,ATM采用固定长度的信元传输。  36.ATM上需要仿真的局域网特性  (1)无连接服务2)组播服务(3)ATM上的MAC驱动(4)仿真局域网(5)与传统的局域网互连  37.试总结一下路由器的功能  (1)路由选择(2)隔离广播(3)网络分段(4)安全和防火墙(5)三层特殊服务(6)广域网的互连  38. 集中方式方案的优点和缺点:  (1)优点:  a.可提供诸如优先权、保证带宽,具有较大的控制访问能力。  b.允许每个站有尽可能简单的逻辑;  c.避免了协调问题。  (2)缺点:a.会出现影响全网的单点故障;  b.会发生瓶颈作用,时效率降低。(分布方式方案的优点和缺点:正好与集中式相反。)  39. 信息通信涉及三个因素:进程、主机、网络  40.碰撞槽时间在以太网中是一个极为重要的参数,有如下特点:  (1)它是检测一次碰撞所需的最长时间。  (2)要求帧长度有个下限。(即最短帧长)  (3)产生碰撞,就会出现帧碎片。  (4)如发生碰撞,要等待一定的时间。t=rT.(T为碰撞槽时间)  41.载波监听多路介质访问/冲突检测(CSMA/CD)  载波监听多路介质访问/冲突检测协议已广泛应用于局域网。其方法是:  每个站在发送帧期间,同时有检测冲突的能力,一旦检测到冲突,就立即停止发送,并向总线上发送一串阻塞信号,通知总线上各站冲突已发生,这样通道的容量不致因白白传送一损坏的帧而浪费。  42.在10BASEX上采用曼彻斯特码。优点为:  (1)传输的代码中包括了同步时钟;  (2)能很方便的检测到发生碰撞的现象,平均电平发生了变化。  (3)容易区分“1”、“0”及非“1”、“0”编码  43.帧突发技术:  (1)当一个站点需要发送很多短帧时,该站点先试图发送第一帧,该帧可能是附加了扩展位的帧;  (2)一旦第一个帧发送成功,则具有帧突发功能的该站就能

够继续发送其它帧,直到帧突发的总长度达到1500字节为止。  (3)为了使得在帧突发过程中,媒体始终处于“忙状态”,必须在帧间的间隙时间中,发送站发送非“0”、“1”数值符号,以避免其它站点在帧间隙时间中占领媒体而中断本站的帧突发过程。  (4)在帧突发过程中只有第一个帧在试图发出时可能会遇到媒体忙或产生碰撞,在第一个帧以后的成组帧的发送过程中再也不可能产生碰撞。  (5)如果第一帧恰恰是一个最长帧,即1518字节,则标准规定帧突发过程的总长度限制在3000字节范围内。  44. 矩阵交换结构特点  (1)地址表:地址——输入/输出端口  (2)利用硬件交换,结构紧凑,交换速度快,时延小;  (3)不易于简单堆叠和集成。(4)使用广泛,如:ATM.复习资料(9)注意:  (1)当输入端口与输出端口相等时,不会发生阻塞;  (2)当输入端口多于输出端口时,就会发生阻塞;  (3)为避免帧的丢失,必须增加缓冲区。  45.总线交换结构优点:  1.便于叠堆扩展;  2.容易监控和管理  3.容易实现帧的广播;  4.容易实现多个输入对一个输出,即客户机-服务器的方式。  46.共享存储器交换结构特点:  (1)使用大量的高速RAM来输入数据;  (2)输入输出会产生时延;  (3)交换器结构简单;  (4)冗余结构比较复杂;  (5)适合小型交换器。  47.厢体模块的三个优点:  (1)维修方便。每一个模块可以热插拔。  (2)高可靠性。 电源备份; 可采用无源母板;有备用交换引擎。  (3)系统集成和配置灵活。  48.FDDI标准中含有加强可靠性的技术规范,为以下三项技术:  (1)站旁路:对故障站旁路;  (2)布线集中器:用于星型布线中;  (3)双环:使网络自动恢复。  49.FDDI的应用领域  后端局域网:连接主服务器和大容量存储设备;  高速办公室网:他们要求从低速到高速的数据传输;  主干局域网:用一个大容量的局域网连接若干各集中器或交换器。  50.FDDI 标准的包含了MAC子层和物理层。标准分为四部分:  (1)媒体访问控制(MAC)  (2)物理层协议(PHY)  (3)物理媒体相关子层(PMD)  (4)层管理(LMT)复习资料(10)51.以太网应用的分类  (1)群组 (2)部门 (3)主干  52.令牌环网与FDDI存在的差别:  (1)FDDI并不是通过改变一个比特来抓住令牌的;  (2)FDDI在一个站完成其帧发送后,即使尚未开始收

到它发送的帧,也立即送出一新令牌。在环上可以有多个帧。  53. FastIP技术特点  FastIP技术特点总结如下:  (1) FastIP技术的思路是设法在数据交换过程中避开第三层路由器。即把基于IP地址路由表功能转化成基于端口——MAC地址表的转发功能,从而实现完全的端到端高速交换通信。  (2)FastIP是基于局域网的第三层交换解决方案,除了3Com的网络接口卡和软件支持外,可以兼容许多第三方产品和技术。  (3)FastIP并不是要替代路由,而是把交换和路由很好地结合在一起。经测试,FastIP可以把网络的吞吐率提高4~5倍。  54. 在802.1Q中定义了两种类型的帧标记:  (1)隐式的帧标记(Implicittagging):隐式的帧标记表示帧所属的VLAN信息并未被明显地标记,该帧属于哪一个VLAN,缺省地由网桥的接收端口号或帧中data域的信息决定。  (2)显式的帧标记。(Explicit、tagging):显式的帧标记表示帧所属哪一个VLAN由网桥 (LAN交换器)所加的标记(VID)显式地决定。  形成以太网显式的帧标记包括以下几个步骤:  (1)在以太网帧中插入VLAN头部。头部插在DA(目的地址)和SA(源地址)之后。  (2)重新计算FCS(帧检验)  VLAN头部包括(4字节)如下信息域:  VPID(VLAN Protocol Identifier),2字节,它表明此帧已按802.1Q协议显式标记。  VCI(VLAN Control Information),2字节,它由以下几部分组成: (见图8.5)  a.User-priority(用户优先)它允许VLAN帧在那些不具备表示用户优先权的网段(如Ethernet)  携带用户优先权信息;  b.TR-encap它置位时(=1)表示该帧data域中携带的是未经翻译和封装的TokenRing帧;  c.VID(VLAN Identifier)它表明此帧属于哪一个VLAN.  55.RIP的工作过程和基本概念  RIP协议的工作过程:  (1)RIP采用主动发送,被动接收的机制来实现路由信息的交换。  (2)RIP有一个路由更新时钟,一般设置为30秒,每个路由器每隔30秒都要把它的整个路由表向其相邻的路由器发送。  (3)RIP定义了一种受激更新。即每当路由器检测到新的网络拓扑结构的变化时,除了重新计算自己的信息外,都要立即向其他方向发送该更新消息。  (4)RIP仅为每一个目的网络保留一条最佳路由。当有新的更佳的路由时,就有新路由代替旧路由。  (5)网络拓扑结构发生变化时,就会自动更新路由。  (6)RIP用时钟保证其性能。  基本概念:  (1)RIP是典型的距离向量法  (2)路由更新时钟:一般设为30秒;  (3)路由器无效时钟:每激活一次,就给每个

路由表项中的时间项加1.如果时间项的值超过规定的无效时间,则把该路由项置为无效,并通知相邻的路由器。一般设为90秒。  (4)路由清除时钟设置为270秒。  56.以太网的帧结构7   1   6   6   2   46~1500   4  前导码  帧首定界符(SFD)  目的地址(DA)  源地址(SA)  类型(TYPE)  数据区(DATA)  帧检验序列(FCS) 复习资料(11)1.)前导码  为101010……,共56位,为了同步。  2.)帧首定界符(SFD)  为10101011,表示一帧开始。  3.)目的地址(DA)  为MAC的物理地址,共6字节。又分为单地址、多地址和广播地址。  (1)单地址:最高位是“0”;  (2)多地址和广播地址:最高位是“1”。(广播地址时,DA同时为全“1”代码)  4.)源地址(SA) 同上  5.)类型(TYPE)  主要说明高层所使用的协议类型,如IP地址。  6.)数据区(DATA)  它的范围为:46~1500字节,如不够46字节,则必须填充到46字节。  7.)帧检验序列(FCS)  FCS是通过计算除前导码、SFD和FCS以外的内容得到的。  四种10BASE以太网物理性能比较   10BASE5  10BASE2  10BASET  10BASEFL  收发器  外置设备  内置芯片  内置芯片  内置芯片  媒体  粗缆  细缆  3、4、5UTP  62.5/125多模 最长媒体段  500m   185m   100m   2km 拓扑结构  公共总线型   公共总线型  星型   星型 中继器/集线器  中继器  中继器  集线器  集线器  最大跨距/段数  2.5km/5  925m/5  500m/  54km/2  网卡上连接端  9芯D型AUI  BNC,T头  RJ-45  ST   58. 高速以太网与10BASET/FL组网性能比较   10BASET/FL  100BASETX/FX  IEEE标准  802.3i/j  802.3u  拓扑结构  星型  星型  传输率  10Mbps  100Mbps  媒体  3、4、5类UTP、MMF  5类UTP、STP、SMF、MMF  最长媒体段  UTP:100m;MMF:2Km  UTP、STP:100m;MMF:2Km;SMF:40Km  编码  曼彻斯特码4B/5B  NRZI  帧结构符合  DIX802。3标准  符合DIX、802。3标准  CSMA/CD  同上  同上  碰撞槽时间  51.US(512bit)  5.12US(512bit)  碰撞域范围  UTP:500m(四个中继器)  2个中继器:UTP、STP:205m;MMF:228m;UTP+MMF:216m;无中继器:UTP:100m;MMF:412m,   59.全双工/半双工的组网跨据  媒体  半双工  全双工 1000BASELX  多模光纤  330

  550 单模光纤  330  3KM 1000BASESX  多模光纤  330  550 1000BASECX  TW型STP  25  25 1000BASET  5类UTP  100  100 100BASET2  UTP  100  100 100BASEFX  多模光纤  412  2km 100BASETX  UTP/STP  100m  100 10BASEFL  多模光纤  2km  2km 10BASET  UTP  100  100   61.快速以太网对10M的继承  100BASETX<-10BASET 的UTP网络环境  100BASEFX<-10BASEFL 的多模光纤  100BASE2/100BASE4<-3类双绞线

更多类似范文
┣ 局域网组网课程设计局域网的规划设计[1].doc 11100字
┣ 简单共享局域网的组建 3400字
┣ 局域网组网课程设计局域网的规划设计.doc 11100字
┣ 更多局域网组网实验报告
┗ 搜索类似范文